• Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

95 k2500 followed me home

plumbtuf

Member
Messages
35
Reaction score
35
Location
Kiowa Colorado
The saga continues. Last night i pulled the front back off the front of the motor and started from 0 and redid the ip gear set up. Put the truck back together and no change, Still no start. I do not understand what the deal is. I replaced the ip, pmd, glow plugs, harness . Checked the grounds . Nothing. I do not understand the electronics on this nor how to set the timing if it wont run. With the gmtd scan hooked up it shows timing at 14 . i dont know what that means. i am not able to change that. Crank it and it bounces around but not by much. Move the pump and restart, value is the same. At this point I think i may cut bait and put my mech pump on it and use the trans and controller from the dually. I really dont want to pull the motor and put it into the dually , still may . All I know for sure is I'm not pleased with my performance and i hate the electronics. Sorry for the rant.
 

plumbtuf

Member
Messages
35
Reaction score
35
Location
Kiowa Colorado
I think it may be a pmd. ordered a another on from Leroy. Hope thats it. It just cranks. Caught once and ran for 10 seconds then nothing. It seems as if wants to catch and run with longer glow plug times , using my glow plug over ride switch.
 

plumbtuf

Member
Messages
35
Reaction score
35
Location
Kiowa Colorado
So i finally got it to run... :joyful: .I re-bled all of the injector lines , cleaned all of the grounds . Now heres the funny part.I put 5 gallons of diesel fuel in it. i dont think it was empty but it was damn close. In my defense I'm a diabetic and when my numbers drop I get spacey and foggy. Not saying the lack of fuel was the cause of my distress, but it didnt help. Now it does take alot of hits on the manual switch to get it to run, and it smokes white really bad. Not water , white stinky stuff. i havent tried to set the timing maybe that has something to do with it. I had a leak from under the manifold,#4 injector line wasnt tight. While I had the manifold off I double checked the firing order so thats good. Just have clear up the smoke and we might have something. Also gonna order a new glow plug harness. Thanks..
 

Will L.

Well-Known Member
Messages
9,445
Reaction score
10,317
Location
Boulder City Nv
Smell the smoke. Diesel smell, coolant smell, oil smell.
All can give white smoke- and the smell is easiest method.

When it runs low, it can aerate really bad causing issues. Also any water or other contamination that may be in the tank settles low.

How does the fuel look in the clear return line?
 

plumbtuf

Member
Messages
35
Reaction score
35
Location
Kiowa Colorado
What a roller coaster this is turning out to be. Still no joy on getting it to run with out a crap load of white smoke.Yesterday it went back to just cranking and catching for a couple of seconds and then dying. i know so little about this ds4 i dont know what else i can check. I think the timing is way off, and i moved to the drivers side but now the starter is toast so i cant check that . Ill have to pick up a new one from autozone or someplace to check this out. I am waiting on a new pmd from Leroy, but both of the ones I have got the truck to run (crappy ). But it ran. Also have a new glow plug harness from quad star on the way. Hopefully I can get this figured out and get it moved ,as the other projects are piling up. I need to get the dually stripped of a few things and off to the crusher .
 

Will L.

Well-Known Member
Messages
9,445
Reaction score
10,317
Location
Boulder City Nv
NEED the clear line and fuel pressure gauge. Can you do the pressure gauge while waiting for starter? Tap it right at the ip inlet.

Starter rule for life:
30 seconds on, 30 seconds off.
30 seconds on, 30 seconds off.
30 seconds on, 30 MINUTES off.

Double check injector lines are proper order.

I feel for ya on the ds4 mess. I know your hearing the db pumps calling...
 

plumbtuf

Member
Messages
35
Reaction score
35
Location
Kiowa Colorado
I had the intake off Saturday and double checked the lines then, they are good. I will get the starter tomorrow and try again. Sad part of the whole thing is that I have a moose Jr that is less than a year old that was going to go back on this motor till my son opened his big mouth about butchering up the truck to go mechanical. Should have just kept the dually complete and I'd be done by now. Now I have to part out the dually and fix this thing. Back in April the boy got back from the Stan and we where driving through town . Sees the truck, Dad that's in so much better shape than the dually. Blah blah blah. I'm a dumbass. When done I'll have a truck that I've spent 7k-8k on that I can sell for about 3k. And it still may end up with the mechanical pump.
 

plumbtuf

Member
Messages
35
Reaction score
35
Location
Kiowa Colorado
I got the starter installed tonight. It ran again, with billowing clouds of white diesely smelling smoke. i'm sure the neighbors that had windows open are pissed. No I still havent done the clear line, but will do that tomorrow night. Could this be low supply pressure? I've ordered a fuel pressure gauge. Are the drain port and outlet port on the FFM separated internally , where you can have flow through drain but low flow at outlet? i do have a code 88 , so thats new. More research to do. Everyday I get closer to putting my db2 on it and calling it done.
 

Will L.

Well-Known Member
Messages
9,445
Reaction score
10,317
Location
Boulder City Nv
The largest possibility is air intrusion way more than a pressure issue. That clear hose takes like 2 minutes. Then start the truck and watch it for 60 seconds. You’ll know instantly if bubbles are going through. Let it idle, blip throttle, high idle then back to idle. Really do that before anything else.

The ffm drain is a separate port from ffm. So it can be ok while the output hose has issues. Look up the pic that WarWagon posted of his hose that was messed up right at the ip inlet as a perfect example. Finding a problem days open things up, but 1 being good doesn’t prove the other is.

You still want to use drain hose for sampling fuel flow volume and fuel quality/ contamination check.

Do the clear hose, run for a minute then if it is perfect while still running put your clean clear glass jar (i use mason jar) at the drain and open drain noting how long it takes to pump 1 pint. Then cover the sample so nothing falls in it and let it settle out for a couple hours then look at it without moving it. I let it sit a full day and look again, as it might take that long for water to separate. I have a habit of writing date and truck id on masking tape and letting it sit until problem is solved.
 

plumbtuf

Member
Messages
35
Reaction score
35
Location
Kiowa Colorado
I wasnt able to do alot on the truck tonight. Was busy with other stuff, will get back on it tomorrow. My son had his truck stolen last night from in front of his apartment. It was a nice bulletproofed 04 F250 PSD 6.0 liter. So its been one hell of a month, the truck not running is the least important of it all. I think I'm on the right track with it. Hopefully getting it going properly will be a nice fathers day gift. Thanks for all the help.
 

plumbtuf

Member
Messages
35
Reaction score
35
Location
Kiowa Colorado
Tonight I put the clear hose on it and got it started and it ran horribly for a few minutes, but no air or bubbles, nothing. Still smokes bad. Won't stay running else I set idle at 800 rpm. Fuel has sat in bottle overnight and looks like diesel fuel no water or crap in it. I don't get it. The timing is off but nothing changes with the position of the IP. I'm gonna start taking the front back off of motor to put the mech pump on. I'll double check the gears when I get to that point, and if that's right wouldn't you think it's the pump? I never asked but how's the track record of accurate diesel and their pump's? I've purchased stuff for my son's power stroke( just stolen yesterday) and never had a problem. Any body interested in a pump , quadstar tune and 3 pmds? They in all likelihood be for sale very soon.
Eric
 
Top