• Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

'03 Silverado 4l60e not shifting out of 1st gear until I lift off accelerator pedal.

Donsc5

New Member
Messages
2
Reaction score
0
Location
Portland,ME
Hi all,

New to the group. 03 4X4 Silverado 4.8- 4l60e with 116K bone stock. My winter truck Since I drive a C5 corvette 8 months out of the year.
Transmission will not shift out of 1st gear unless I lift off the gas pedal. Almost like you would if it was a manual. once 2nd gear is achieved, transmission works completely normal. About the same time this happened I lost a few gauges in my instrument cluster.... including the speedometer. I will be honest. Since its not my Corvette? I don't take care of this truck like I Should. I replaced the VSS thinking it would help. It did not. I sent out the gauge cluster for repair and got it back in perfect condition. All gauges work now but transmission still not coming out of first gear properly. I assumed (wrongly) that to shift, the computer looks for RPM, Speed, etc when determining when to shift. And I assumed that since there was no Speed? it was confused until I let off the gas, and it shifted fine. This transmission works completely normal other than when to leave first gear. I'm dumbfounded. There is no CEL involved at all.

Can anyone point me in the right direction? does the Computer need to re-learn shift points now that my speedometer works again? this issue has been over a year... I've gotten so used to driving it this way that I don't even think about it anymore... I just want it to work properly.
 

Jaryd

Extremely Deplorable
Messages
1,346
Reaction score
1,996
Location
Hodges, SC
Have you put a scanner on it yet. Some transmission codes won’t trip the CEL.
 

Donsc5

New Member
Messages
2
Reaction score
0
Location
Portland,ME
Have you put a scanner on it yet. Some transmission codes won’t trip the CEL.
Humbly I will say no I have not put a scanner on it. I don't have any access to one. And once again I will admit this is not my Corvette (The C5 does not need a scan tool, you can access error codes thru the DIC) so I do not make this truck a priority as I should. I own 3 vehicles and this one is last on the list. I was hoping for a " Hey dummy? change this part and it will be fixed... I've seen it a million times".... But sadly I'm realizing that if I want the transmission to shift out of 1st properly? I'm going to have to Throw money at this at a transmission repair shop.
 

THEFERMANATOR

FRANKENBURBAN
Staff member
Lead Moderator
Messages
9,665
Reaction score
3,514
Location
ZEPHYRHILLS FL
About the only thing that comes to mind to check without a scanner is to get some maf cleaner and clean the maf sensor. The speedo working or not has no bearing on how it shifts provided the PCM is getting the speed sensor signals. They shift using a strategy of engine rpm's, vehicle speed, and applied power which is calculated using throttle position and mass air flow. A dirty maf is the #1 cause of a late shift with no codes present. Other than that you need to get a scanner on it to check for codes and to see what it is doing, or not doing.
 
Top