1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Vane Position Sensor

Discussion in '04.5-05 LLY' started by Ed HD, Feb 23, 2014.

  1. Ed HD

    Ed HD Formerly: Dad's 05 LLY

    3,066
    240
    Jul 6, 2008
    Lakeville, Minnesota
    So, the CEL has been on in the 05, code reads Turbo Vane Position Sensor, don't remember the code. I can go grab it if needed. IIRC it's not worth cleaning it? Is AC Delco my best bet? RockAuto has an AIRTEX/WELLS for $320, I don't want to know how much a dealer is going to want. How hard is it to replace?
     
  2. Ed HD

    Ed HD Formerly: Dad's 05 LLY

    3,066
    240
    Jul 6, 2008
    Lakeville, Minnesota
    I knew there were a couple threads. Might need to take a trip to visit my buddy who has a Tech II then...
     
  3. Ed HD

    Ed HD Formerly: Dad's 05 LLY

    3,066
    240
    Jul 6, 2008
    Lakeville, Minnesota
    Update: I cleared the code, then while doing a few other things I pulled the sensor and cleaned some gunk off the tip (used MAF cleaner as to not do any harm) and put it back in, haven't heard any issues since. Hope that's the end of that issue for a while. AFAIK, that's the first time the SES has ever come on...
     

Share This Page