1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!
  2. The web host will be conducting critical patching on the server this Sunday @ 7PM. Downtime will be a maximum of 2 hours, please see this thread for more information:

    View the thread

P 0299 Code

Discussion in '06-07 LLY/LBZ' started by RI Chevy Silveradoman, Apr 11, 2011.

  1. RI Chevy Silveradoman

    RI Chevy Silveradoman At your service Staff Member

    Joined:
    May 3, 2008
    Messages:
    8,432
    Likes Received:
    25
    Location:
    Rhode Island
    Code: P 0299
    Modules: ECM
    Description: Turbocharger Engine Underboost

    I got the dreaded P0299 code over the weekend. The truck ran no differently. I did a little research and found that the Hypertech tuners like to throw that code. I cleared the code, and went out and hit the accelerator hard a few times from a stop to help clear out the soot. It seems to be running fine. I have no gauges as of yet, so I cannot tell if I actually have a low boost issue. Just going by the seat of the pant driveability.
     
  2. Mad Maxx

    Mad Maxx See, what had happened was... Staff Member

    Joined:
    May 3, 2008
    Messages:
    5,967
    Likes Received:
    39
    Location:
    Long Island, NY
    Maybe the Tuner needs Updated?
     
  3. RI Chevy Silveradoman

    RI Chevy Silveradoman At your service Staff Member

    Joined:
    May 3, 2008
    Messages:
    8,432
    Likes Received:
    25
    Location:
    Rhode Island
    It has the correct upgrades. I think it was just a rogue code.
     
  4. trotorx2

    trotorx2 New Member

    Joined:
    May 10, 2008
    Messages:
    304
    Likes Received:
    0
    Location:
    Beaumont, Texas
    When I still had mine right before I upgraded to the Predator my Hypertech started doing some really weired stuff but no codes.

    I started seeing Tons of smoke and bad defuels when at WOT. Never thru any codes. I really didn't like the Hypertech in general.
     
  5. blizzardplowman

    blizzardplowman Crowd Control Staff Member

    Joined:
    May 3, 2008
    Messages:
    649
    Likes Received:
    0
    Location:
    SE WI
    mine would show the P0299 and afterwhile is was actualy the sensor that I had to have replaced.
     
  6. RI Chevy Silveradoman

    RI Chevy Silveradoman At your service Staff Member

    Joined:
    May 3, 2008
    Messages:
    8,432
    Likes Received:
    25
    Location:
    Rhode Island
    What sensor Marty? Turbo vane sensor?
     
  7. blizzardplowman

    blizzardplowman Crowd Control Staff Member

    Joined:
    May 3, 2008
    Messages:
    649
    Likes Received:
    0
    Location:
    SE WI
    Yes, fairly easy fix if you are out of warranty.
     
  8. RI Chevy Silveradoman

    RI Chevy Silveradoman At your service Staff Member

    Joined:
    May 3, 2008
    Messages:
    8,432
    Likes Received:
    25
    Location:
    Rhode Island
    OK Thanks Marty. I cleared the code and it has not returned as of yet.
     
  9. btfarm

    btfarm Quarter Million Worth Staff Member

    Joined:
    May 12, 2008
    Messages:
    14,469
    Likes Received:
    149
    Location:
    Sandwich, Illinois
    Hope it lasts for you Jeff. Those aren't cheap IIRC.
     

Share This Page