• Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Recent content by plumbtuf

  1. P

    95 k2500 followed me home

    Here is a screen shot of the timing numbers before activating time set. Do these look strange or out of whack to anybody. Now with the temp over 170 when i push the time set button the the numbers bounce from 2.0 to 3.6 . Then it dies. numbers where 0/3.4/1.50 .The physical position of the pump...
  2. P

    95 k2500 followed me home

    So the hard start saga continues. For the life of me i cannot figure out the timing on this truck.It seems to run ok ,but any start produces large clouds of smoke.I know the timing must be off, but any button i push time set/tdco learn and the truck dies. Right now the FSO is all the way over to...
  3. P

    Poor Boy Special 6.5 Refresh

    I know this is an old thread, but i keep coming back to it . The work is great. Hope its still going strong.
  4. P

    Any updates on your truck. Curious how your turbo and injection pump have been doing?

    Any updates on your truck. Curious how your turbo and injection pump have been doing?
  5. P

    95 k2500 followed me home

    It's not that the high egts , it's the rate at which they rise before the truck starts to get going. Sometimes I'm pushing 16 to 18 boost and 1100 at 60 mph. It just seems off to me. Maybe I'm wrong. But it seems wrong.
  6. P

    95 k2500 followed me home

    Yeah, that's what I keep hearing don't worry about it . But doesn't he blow alot of crap up.
  7. P

    95 k2500 followed me home

    Really havent been doing much to the truck lately. I still dont feel that this is a good combo, but havent decided what I want to do with it.To me the egts get to 800 with part throttle by 40 mph. Very little smoke on 3 of the 4 tunes, only the performance tune produces smoke until the turbo...
  8. P

    95 k2500 followed me home

    As far as the boost goes I've seen as high as 16, but egt will climb rapidly to 1100 . At that point I get out of it. The truck doesn't really blow any smoke unless its on the performance tune , then its smoke and egts I don't like.Johns tune is the real deal, its has been alot better on this...
  9. P

    95 k2500 followed me home

    I thought an intercooler would make the lag worse with an ATT. Is it more about the density? so intercooler and wmi?
  10. P

    95 k2500 followed me home

    The carter lift pump is about 6 months old. It will hold 9-10 psi in the morning and then in the afternoon when its warmer at idle it is around 5psi and 3-4 under load. so it dosent seem to be as efficient when its hot out. The biggest problem I have right now is the ATT turbo, I dont think its...
  11. P

    95 k2500 followed me home

    This truck is driving me nuts. Now its throwing codes 18/35/54. Is this due to grounds? Also i have noticed that the fuel pressure is dropping off. I have 9 psi at idle and 3/4 while rolling down the road under acceleration . It has a carter lift pump on it and Leroy's fuel pump harness. Thanks...
  12. P

    95 k2500 followed me home

    I continue to drive the truck and overall Iam happy with how it runs. In my last post i mentioned that it had an exhaust leak, Well it wasnt an exhaust leak. When I put the truck together I installed a oil pressure gauge and just set it on the trans hump.Its only temporary until i get my gauge...
  13. P

    95 k2500 followed me home

    Well it finally runs. I was able to get the pump set where the computer likes it . -1.50 is where it is set at right now. I have just started driving it a bit and it runs well, although the glow plugs dont appear to be working right. I have changed the controller , harness and reused the old...
Top