• Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Accelerator wires and sparks and big trucks and stupid GMC designers and anything else not covered

GMMomma74

Mother of Trucks
Messages
49
Reaction score
67
Location
Texas
So I am hot (heat wave in my part of Texas with triple digit heat indexes), tired of my truck not running and my crazy husband talked me into listing her on Facebook marketplace for a measly grand. You would not believe how many people think they should be getting a perfectly working vehicle for that price. Especially when the title alone is worth at least 500.

But I digress. If you don't want to read my "book" turn away now..

Anyway I put it up at 6pm Sunday. Had first interested buyer come out at 10pm. Thank the Lord I didn't have to work Monday. Anyway we had put new pmd on with no resistor. Rpm's shot way up. Took pmd off and added resistor. Ran like a purring tiger kitten. Until prospective new owner decided to test why it won't reverse. Beast baby screamed and shut off. Being as it was dark out (not many street lights when you live 1/4 mile off the back road in between a couple cattle fields) and me at the front of the truck I noticed sparking when trying to start it back up from a little black canister at the driver side firewall with the app wire (I think) running into it and another wire coming off it (to ecm/main computer?). Anyway guessing that is the culprit to her "surging" and runawayness. And thanks to said buyer who busted the top of my fuel filter I need a new one.

Any ideas? Thinking definitely app and or wiring to it.
Oh and I haven't recieved the obd1 reader yet. Church staff was out last week and haven't heard anything yet this week.
And I learned the IP has been changed out at some point so most likely not the culprit.


Sorry guys but I just can't give up on my first (and definitely not last)big truck. Altho the next may be a bit smaller and gas to appease the grumpy old man I married (honestly I married a 23 year old skate rat with rock legend dreams I was 21 with dreams of housewifery, 23+years ago)...
 

Attachments

GMMomma74

Mother of Trucks
Messages
49
Reaction score
67
Location
Texas
Starts just as well as it always has...

Is there a way to clear the computer codes without a scan device?

Oh and a friend of mine is selling an obd2 for $5.
 

NVW

Well-Known Member
Messages
8,857
Reaction score
1,758
Location
Castor, AB.
Starts just as well as it always has...

Is there a way to clear the computer codes without a scan device?

Oh and a friend of mine is selling an obd2 for $5.
IIRC turn ign. on, put it in drive and hold both the accelerator pedal and brake down for 30 seconds. Or disconnect the batteries for 15-30 minutes.
 

GMMomma74

Mother of Trucks
Messages
49
Reaction score
67
Location
Texas
Thank-you. After some fasting and prayer (sorry folks I'm a good Christian girl) I feel peace that it's biggest problem is that Chinese wire harness for the pmd that I've been using. Can that cause me to kill the pmd's or is it more of a passive part (pmd) that once I get a good wire it will behave properly?
I so want to be a good diesel truck Momma.
 

GMMomma74

Mother of Trucks
Messages
49
Reaction score
67
Location
Texas
Thanks. I'm gonna hoof it the 2 miles home from work... If I don't die on the way... Snatch the pmd out of the bumper and hook it up to the wire without the extension and see what she does. I may have to run like that for a week til I can order a new wire (from a reputable dealer)... And then get a new one with lifetime warranty and install in other liscence plate bolt in bumper. Then when one dies I have another... Then once I get it running figure out what else is wrong...
 

WarWagon

Well it hits on 7 of 8...
Messages
8,994
Reaction score
4,030
Location
AZ
So are you selling it or keeping it? Pictures, link, etc. Never know who on here is looking for a truck. Shop around for a good trans shop. Ballpark decent rebuild runs me a grand (plus hard parts like gears) in and out and lasts 50K miles rode hard and put away wet.

Solve the PMD problems, make sure the lift pump is working aka bust the top of the fuel filter :p and keep it below 210 ECT and it will run great till the second it lets loose. Run-away RPM can bend valves and loose compression: ask me how I know, actually: don't. You already know cheap PMD cables can do this... Old PMD's can also do this as some had re-designs to "fix" that.

Either way you found a great place to get it running and keep it running. Frugal or "what is your budget?, "unlimited!" " can be found here. Welcome to TTS.
 

GMMomma74

Mother of Trucks
Messages
49
Reaction score
67
Location
Texas
Lift pump working like a dream (I was so worried I'd fried it).
Pretty sure it's biggest problem is pmd and wiring harness from china. Tried plugging it up right to the wire coming from the ip. No luck ( did I already fry this old that Stoney so graciously sent me?)... Tried with and without resistor (better luck with resistor). Gonna unplug both batteries fully and let sit a day and try again.
Transmission been told a flush and filter should help. If not $750 can get me a rebuilt from down near Houston. They'll ship for free to a shop.

As for selling I've been outvoted by the 3 other people in my family. Altho I'm the Momma so my vote is 4 times what theirs is. If I can get it running at least as well as it was I'm sure we will be able to hold out for more $$ and/or wait for the enquiries that I'd like to have the truck have it (pair of disabled brothers needing a truck to pull their racing team trailer).
I'm in East Texas about 70 miles from Dallas and 70 miles (give or take) from the Louisiana border.
$1000 or trade for a running (doesn't have to run pretty or look pretty) minivan or car.
What doesn't show is the nice ball/gooseneck hitch in the bed. And there is a square tube under the ball at the back is you need a different size bumper pull. Very versatile little one (1 ton). A/C is amazing when fully charged. Only interior damage is driver seat has a rip (there when we got it) and passenger needs new inside door handle. Opens just fine from outside.20190707_161535.jpg20190707_161612.jpg20190707_161637.jpg20190707_161705.jpg20190707_161814.jpg
 
Last edited by a moderator:

GMMomma74

Mother of Trucks
Messages
49
Reaction score
67
Location
Texas
Exactly what its doing. So I think a bad wire harness is burning up my pmd's...

Just need to get it running so I can get a title loan to keep it running til I can get a second vehicle.
It does run and drive and purr like a sleepy cranky tiger kitten when she has everything she needs...
Just so tired of going around in circles with this truck...
 

GMMomma74

Mother of Trucks
Messages
49
Reaction score
67
Location
Texas
I looked on his website and it says he's in Houston. About 4 hours from here.
Right now its a no at issue. At this point I don't know if I'll have any electricity past 9am tomorrow. And my husband is on oxygen and... Just an overload.
Regardless of what the people who are trying to lowball me on the price I do know the truck runs good and strong. It has an issue with reverse (only kicks back about a foot unless on a downhill backwards slant) that is very workaroundable... You really don't need reverse unless towing. Even then my 22 year old daughter who was a high school state level powerlifter and can push the Beast with ease (incidentally her name is Becca the Beast).

Was just talking to my husband after tuning in to church on Facebook (our church broadcasts live and then saves the video) and our only issue in life is money.
 

WarWagon

Well it hits on 7 of 8...
Messages
8,994
Reaction score
4,030
Location
AZ
That's a pretty straight body and good dual fenders for age/miles. The dent free tailgate... this wasn't a work truck for sure.

Have you pulled codes? Maybe it's (reverse issue) something electrical including an electrical problem the, ahem, antique ECM computer even sees.

The PMD on the pump, in your picture, is dead? Maybe eliminate the extension cable and see if it runs off the PMD mounted on the pump? Or other PMD just tossed under the hood on the OEM wire harness only. Again always have the PMD on a heatsink or they quickly overheat and fail.

Looks like the air filter needs a service, and although that hot air K&N type setup is not ideal, some of us overlook a dirty clogged up air filter when troubleshooting.

Grounds are one of the first recommendations to look at. Take apart and clean them.
 

Stoney

Lock-n-load
Messages
481
Reaction score
750
Location
Elmira ny
That's the biggest problem I had when I first got mine was chasing down ground problems... If I read correctly she tried plugging directly into the pump already..
With my truck I fried 3 p.m.ds before I figured out that one of my sensors was causing it.. I changed my temp control sensor and my crank position sensor I never had another problem but I also did a lot of ground cleaning at the same time so I'm to this day not exactly sure which was the culprit.. I do know those sensors control a whole lot of crap..
Do you by any chance know anybody down there that has a 6.5 truck?? I'm only asking because the only way to tell if your p.m.d's are still good is to plug them into another truck that runs...
 

GMMomma74

Mother of Trucks
Messages
49
Reaction score
67
Location
Texas
Don't know anyone with anything close to mine.
Tried plugging it direct and got nothing. Too hot out right now to fuss with it.
My daughter just started working again and will be getting her first full 2 week check on the 31st. Gonna get a hold of Leroy Diesel and see what we can figure out.
Haven't been able to get to church and get the code reader or get anyone to deliver it.

Yeah new air filter needed, and replace the fuel filter... Again... And get it into the shop as soon as I can afford it. Gonna probably try another pmd (one on injector pump is dead) and hook it direct and get a new wire as well. I do need to unplug the batteries and reset the dang thing. Just too hot... And when its not I'm working and too tired.

Once I can get it running again I'll start testing pmd's. Hoping I have a pile of good ones and just a crap wire...

Now to get to bed... Its 12am Sunday and I've been up since 4:30 am Saturday.
 
Top