• Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

4l80e. No drive and no reverse 1st-3rd works

Why would 1st -3rd work but Drive and Reverse revs up, ive got a 0

  • ?

    Votes: 0 0.0%
  • Confused

    Votes: 0 0.0%

  • Total voters
    0

Sharpee

Ride wide open......
Messages
5
Likes
4
Location
Lake forest california
Thread starter #1
OK I have a 2003 lifted silverado 2500hd crew cab 6.0 vortec, 4L80e trans that has always shifted pretty hard if I don't let up into 2nd gear. So I have mostly always left off the gas just in time for the shift. the rest of the gears seemed to be smooth. Just recently ive had my truck pop out of gear but re-engage right away. I wasnt sure why it happened but it did it again but engaged back on its own again. (im a learn as my stuff needs repairs kinda girl, between my heavy research ability, google and youtube, weve done amazing for self taught)that said last night it popped out of gear again just before a stop it removed up when I went to take off so I put down in to 3rd and drove home.the only other dealings I've had with tranny was on my tahoe that went into limp mode and becuz myself and no one else could figure out why the random misfire i had and fix it it finally went into limp mode and never got it out. I dropped the pan changed the fluid the filters the solenoids the sensors and all the things of course in the engine nothing worked so now this truck I installed a new radiator not too long ago and have discovered that there was not an oring in either the oil cooler or trans cooler where u plug it in to radiator so I found a slow leak but never have had a problem so I made sure the trans had fluid i added more and ran it thru the gears one by one it acts like it wasts to engage on D and R but it won't it just revs but I can put it in either of the 1st- 3rd gears and runs just fine what could this be on and there r no codes and no check engine light either
 

Attachments

Last edited:

Sharpee

Ride wide open......
Messages
5
Likes
4
Location
Lake forest california
Thread starter #4
My experience with reverse has always been a broken band
R4v
So that means going in the whole ttanby anyways huh. I'm gonna try a few more less expensive things first but thankxi I read to clean maf, my kand n filter. throttle position sensor and possible the filter when I drop the pan andchange up the stuff inside while I'm there ,
 

THEFERMANATOR

FRANKENBURBAN
Staff member
Lead Moderator
Messages
9,283
Likes
2,808
Location
ZEPHYRHILLS FL
Staff #6
No reverse is normally a broken band or cracked apply piston in early units. Hard shifting is bad, so I'm going to guess you have a problem in the center support area. Hard shifts can break the forward apply piston and roller clutches as well as rip the band anchor loose. I would say yours trans is done for, but you need to also find out why it was shifting hard or else you'll just take out your replacement trans.
 

WarWagon

Well it hits on 7 of 8...
Messages
8,697
Likes
3,425
Location
AZ
#7
R4v
So that means going in the whole ttanby anyways huh. I'm gonna try a few more less expensive things first but thankxi I read to clean maf, my kand n filter. throttle position sensor and possible the filter when I drop the pan andchange up the stuff inside while I'm there ,
No amount of "less expensive things" are gonna fix a internal hard part failure. Save your money.

Send your oil coated MAF to K&N and see if they will pay for the toasted transmission. :p HA-HA... Seriously run a window screen, nothing, or a real filter that won't oil coat the MAF and allow a bunch of dirt in anyway. Just about anything is better than a K&N.

Pull codes. Trans issues don't turn the "service engine emissions" light on. <-- see what I did there?

Does it have a shift kit? Does it have an aftermarket tune? Both?
 
Top