• Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Search results

  1. Fola1968

    Major 4l80e problems

    Thanks
  2. Fola1968

    Major 4l80e problems

    What did you do about the electronics?
  3. Fola1968

    Hope to get time to check out my 4l80e in the 97 tomorrow

    Hope to get time to check out my 4l80e in the 97 tomorrow
  4. Fola1968

    Hello new here

    97 k2500
  5. Fola1968

    4L80E no overdrive

    Wondering why it's achieving the correct gear ratio, but not the gear itself
  6. Fola1968

    4L80E no overdrive

    Transmission fluid and filter was changed less than 100 miles ago with normal findings in the pan
  7. Fola1968

    4L80E no overdrive

    Also while running around 60 or more steady speed light throttle, you can feel a very, very hesitation and or pull extremely light pulsing in the vehicle while in OD
  8. Fola1968

    4L80E no overdrive

    Appreciate all the info just being able to get back to the truck know, figured i would share little bit more info of what the transmission is doing, first off did have a service accelerator pedal sensor, checked with the scanner and it did have a sometimes dead spot in the voltage on the scanner...
  9. Fola1968

    4L80E no overdrive

    Also im new to the 6.5 and engine coolant temperature never seems to get above 165 degrees
  10. Fola1968

    4L80E no overdrive

    I'm having a similar problem with my 97 gmc k2500 6.5 shifts smoothly torque locks in 3rd but no overdrive according to solus scanner it's commanded, shows 4th but isn't actually in 4th pulling shifter back to 3rd has no change, still need to do another run test to get more data, im a new user...
Top