1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

tail light problems

Discussion in 'Electrical' started by MattZ71, May 23, 2008.

  1. MattZ71

    MattZ71 Tennessee Diesel's Mod

    355
    0
    May 16, 2008
    KY/TN line
    i have a 97 z71, and i cant get the rear driver side tail light to work, i have replaced the bulbs and circuit board many times and the fuses are fine? any thought guys?
     
  2. kachurak

    kachurak New Member

    227
    0
    May 3, 2008
    Watertown, NY
    probably sounds simple, but did you check it to see if it's getting power with a circuit tester? Could be a wiring issue if it's not, or... ?
     
  3. MattZ71

    MattZ71 Tennessee Diesel's Mod

    355
    0
    May 16, 2008
    KY/TN line
    well Matt i didn't do that ill get one and try that, if theirs no power to it.....where do i start?
     
  4. kachurak

    kachurak New Member

    227
    0
    May 3, 2008
    Watertown, NY
    Well, you're probably going to want to try the socket. Then on the other end if you have no power. If you DO have power on the board end, you're wiring is jacked. This is only an assumption, but will definitely narrow it down to your wiring. I'm no expert by any means, just a tinkerer. I'm sure someone else more versed in electrical here can help.
     
  5. rdean

    rdean Recruit

    47
    0
    May 6, 2008
    Check the ground. If you loose the ground there will be no voltage to measure.
     
  6. MattZ71

    MattZ71 Tennessee Diesel's Mod

    355
    0
    May 16, 2008
    KY/TN line
    my ground wire for both of my tail lights are grounded to my Reese hitch and the other tail light works perfect! i don't understand
     
  7. just a number

    just a number Active Member

    1,431
    2
    May 26, 2008
    Trenton ON
    did you check to make sure the ground was good? I've had wires break inside the casing with no marks on the outside. the other thing to check is the trailer wiring. their known to cause issues too.
     
  8. truckie481

    truckie481 Dagum

    682
    0
    May 4, 2008
    Cleveland, NY
    X2 on the trailering harness, it realy monkey butted my 03 silverado up.
     
  9. MattZ71

    MattZ71 Tennessee Diesel's Mod

    355
    0
    May 16, 2008
    KY/TN line
    thanks guys ill check my ground and trailer wiring in the morning ill tell you guys what i find and if nothing maybe yall can help think where else to look at!!
     
  10. jrkrace

    jrkrace Recruit

    550
    0
    May 9, 2008
    Connecticut
    If the trailer plug "T"'s into the wire harness, bypass it. It worked for my 95 1/2 ton when I had it.
     
  11. MattZ71

    MattZ71 Tennessee Diesel's Mod

    355
    0
    May 16, 2008
    KY/TN line
    well guys i figured it out, i cleaned out the plug that goes into the circuit broad and re-placed all 3 bulbs.....now my brake lights wont work....only when they wont to! but the turn singles are fine!!! i need to trade in!
     
  12. truckie481

    truckie481 Dagum

    682
    0
    May 4, 2008
    Cleveland, NY
    Easy birthday boy, don't give up yet. Take the plug apart again and see if there are any loose connections or debrie. You have come this far it wont hurt to try again. Good luck and Happy Birthday. :hurray:
     
  13. MattZ71

    MattZ71 Tennessee Diesel's Mod

    355
    0
    May 16, 2008
    KY/TN line
    ill try that, and thinks man!!!!! your the first to tell me!!
     
  14. MattZ71

    MattZ71 Tennessee Diesel's Mod

    355
    0
    May 16, 2008
    KY/TN line
    well i found out what the brake light problem was, there is a plastic piece that has to be snapped on to the brake peddle.....mmmm didn't know that piece was there!?
     
  15. truckie481

    truckie481 Dagum

    682
    0
    May 4, 2008
    Cleveland, NY
    I just love a happy ending.:biggrin5:
     
  16. just a number

    just a number Active Member

    1,431
    2
    May 26, 2008
    Trenton ON
    always seem to be the last thing you think of. Glad to hear you found it.:thumbsup:
     

Share This Page