1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

stalling 6.0 L

Discussion in 'Any Other Gas Engine' started by eng158, May 8, 2008.

  1. eng158

    eng158 Deputy

    726
    0
    May 5, 2008
    NY
    Ok guys next question for you all. What is wrong with my truck.

    here is when it stalls any ideas for the problem would be great, as well as any possible repairs.

    Engine is cold, not quite at normoal operating temp, i am turining generally a hard turn, not giving gas, slow speeds and then bam it stalls. When it does not stall in those senarios i watch the volt meter get very bouncy. it will go from above 12, or whatever the middle line is, to way below to above for about 10 sec. it does it about once or twice a week. any ideas? thnaks guys.
     
  2. jeffjbar

    jeffjbar Recruit

    244
    0
    May 7, 2008
    Paducah, KY
    Does it run rough at other times?
     
  3. eng158

    eng158 Deputy

    726
    0
    May 5, 2008
    NY
    kind of but nothing like my old POS jeep. it idles rough especially when cold but only when it does the whole stumble thing.
     
  4. jeffjbar

    jeffjbar Recruit

    244
    0
    May 7, 2008
    Paducah, KY
    I have had a "dying" battery make my truck run like shit and stumble, have you checked it?
     
  5. eng158

    eng158 Deputy

    726
    0
    May 5, 2008
    NY
    i replaced it when this whole thing starterd a few months ago. helped for about a week and then the probllem started again. generally the seat heater is on, radio is on, and heat/AC is on but lowest setting. dont knwo if any of those things paly into it. thanks for the tips jeff.
     
  6. Nor-Cal Nick

    Nor-Cal Nick Suspension Consultant

    540
    1
    May 5, 2008
    Livermore Ca.
    .. I thoought it was another truck... sorry
     
    Last edited: May 8, 2008
  7. eng158

    eng158 Deputy

    726
    0
    May 5, 2008
    NY
    Nick you had me all excited with a possible solution. thanks though. i guess the stalling truck saga continues. any one else with some input. it gets annoying when i get to the top of a curvy on ramp with a stop sign and it dies, especially when dealing with NYC traffic.
     
  8. Nor-Cal Nick

    Nor-Cal Nick Suspension Consultant

    540
    1
    May 5, 2008
    Livermore Ca.
    Sorry wish i could help.... I thought it was a 6.0L powerstroke:frown2:
     
  9. eng158

    eng158 Deputy

    726
    0
    May 5, 2008
    NY
    no no diesel, wish i had one but dont have the money. at least not until i am done with college.
     
  10. monel_funkawitz

    monel_funkawitz Recruit

    36
    0
    May 7, 2008
    Sticking IAC can do it, as EGR and a bunch of other things.

    Getting any codes?
     
  11. Mad Maxx

    Mad Maxx See, what had happened was... Staff Member Moderator

    5,995
    118
    May 3, 2008
    Long Island, NY
    My old S-10 Blazer did this. Was a stuck and clogged EGR Valve.
     
  12. 66FLH

    66FLH "The Big Kahuna"

    943
    0
    May 7, 2008
    New Mexico
    Check the MAF,make sure it's clean.
     
  13. eng158

    eng158 Deputy

    726
    0
    May 5, 2008
    NY
    ok thanks i will give all of those a try. i dont believe it is throwing any codes.
     
  14. Drillchart

    Drillchart Recruit

    14
    0
    May 9, 2008
    CT
    Another shot might be to check the Alt. You stated that the problem went away right after a new battery was put in for a short time, it may be the alt is not producing enough at low engine speeds to compensate for all the extra stuff you may be running and with a new fully charged battery that was able to handle the extra load for a short time.
     
  15. eng158

    eng158 Deputy

    726
    0
    May 5, 2008
    NY
    yeah i have been thinking that. yesterday the truck was really acting up when i had the defroster on. while on the highway when i would take my foot off the gas the voltage would really drop. i thought i was going to stall when i hit traffic.
     
  16. Drillchart

    Drillchart Recruit

    14
    0
    May 9, 2008
    CT
    Better get it checked quick before it takes anything else with it. When I worked as a mechanic I did a lot of battery, alternator stater combo replacements because people let the problem persist and it ended up frying them all.
     
  17. Lloyd Christmas

    Lloyd Christmas Santa's Fake

    35
    0
    May 9, 2008
    Southwestern, CT.
    Josh talk to Puma, he has a battery/electrical system tester. That will tell you if it is the alt. or not.
     
  18. Moore87

    Moore87 New Member

    8
    0
    May 10, 2008
    Had this problem with my dad's 6.0. It was a bad ground connection at the battery. I would say check the grounds
     
  19. eng158

    eng158 Deputy

    726
    0
    May 5, 2008
    NY
    ok thanks all. i guess i will go use my buds tester start from step one.
     
  20. Moore87

    Moore87 New Member

    8
    0
    May 10, 2008
    Let us know how it goes
     

Share This Page