1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

I think I saved my injectors!

Discussion in '01-04 LB7' started by D.Camilleri, Aug 22, 2012.

  1. D.Camilleri

    D.Camilleri New Member

    77
    0
    May 30, 2008
    Worland, Wyoming
    I went on a road trip fishing in Canada last week and about 500 miles into the trip, my truck started smoking grey smoke very heavy at idle and noticeable at all rpm ranges. I added 40 oz of power service grey bottle diesel kleene and kept trucking towing my 16.5 foot boat. The smoke was there all the time and I could tell I was overfueling. I changed tunes on the PPE and went from 6 down to 3 and then back to 4 trying to find a sweet spot that would run without killing all the mosquitos in Saskatchawan. Made it to the final destination still smoking pretty bad. Parked the truck for a week and went fishing. Started the truck up getting ready for the 1000 mile trip home and the smoke was pretty bad at idle. Dropped the tune to level 2, still didn't help much and headed for home. I could tell I was throwing a lot of soot since my boat cover was turning black. Had to stop and buy some fuel and added another strong dose of diesel clean and continued home. By the time I got home, the smoke was still there, but not as bad. I topped off with fresh fuel and added another 40 oz of power service. Drove the truck to work and hooked up the scan tool. Two injectors were suspect with number 8 being -4.1 and 7 at -2.8. I left the scan tool hooked up for another day and a half and checked the rates each time the engine had warmed up and noticed the balance rates were getting better. On tuesday morning, I changed the PPE back to level 6 and made a couple WOT runs on the way to work. When I pulled in front of the shop, low and behold, no smoke! I checked the balance rates and #8 was down to -1.8 and the rest we close to 0. The engine is continuing to run well, and the smoke is gone. I am thinking that I had several stuck plungers and they finally cleared up with the heavy dose of cleaner. My injectors are the latest version of Bosch remans that were installed in 2009 and they have about 70k on them. Engine has 195k.

    I was almost ready to pull the trigger and buy another set of injectors and install them and then send these out for testing, but I am glad I waited. Now I think I will send out my spare set and get them tested.
     
  2. Dieseldad97

    Dieseldad97 I now know why.

    Whew huh? Good for you. I also use DK, but not as often as I should. I ran out about two months ago and thanks to your thread...I'll be buying some tomorrow.
     
  3. Pepperidge

    Pepperidge Member Advocate Staff Member Lead Moderator

    12,354
    343
    Feb 10, 2008
    Slidell, La
    Glad to hear...sounds about like the dose I used to add whenever I went to the track...

    I use DK and the Lucas brand additive now... a little splash of each and I get a warm fuzzy feeling...;)
     
  4. tanman_2006

    tanman_2006 Just a farm kid...

    5,419
    433
    Feb 15, 2010
    Seiling, Oklahoma
    I am using ~60/40 Power Service Silver/ 2 stroke. I run a double dose when towing and working hard. I normally run Cenex #1 on long highway trips. My truck sounds ALOT happier with the 2 stroke in there, almost sounds like a powderchoke w/o it. Balance rates confirm the difference, idc if people think its a waste, my truck likes it and thats what i need most.

    Glad you have found what your truck likes but I would suggest keeping a close eye on them and be ready with another set.
     
  5. David MF Tibbitts

    David MF Tibbitts New Member

    3
    0
    Jan 26, 2016
    maricopa az
    What additive are you talking about? My truck is smoking it was put on a scanner and the guy told me number 6 injector wasnt working right, I was going to replace the injector
     

Share This Page