1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Hot ESO While Cranking

Discussion in 'GM 6.5 Diesel Engines' started by 89SWB1, May 8, 2008.

  1. 89SWB1

    89SWB1 Recruit

    9
    0
    May 8, 2008
    I'm replacing the injection pump, bled air out of filter, and cranked for three 10-second sessions. With #3 injection line cracked, no fuel came out. Have power to ESO, but noticed for the first time it was very warm to the touch. Earlier reply on DP mentioned if plunger not activating, would cause the high temp.

    This is a rebuilt IP from Peninsular Diesel.

    Any help greatly appreciated!
     
  2. monel_funkawitz

    monel_funkawitz Recruit

    36
    0
    May 7, 2008
    Crack the vent on the fuel filter and with the lift pump running, see if you got fuel.

    If an armature is not pulled in a solenoid, very simply, it can't get rid of the magnetic flux, so it gets rid of the energy as heat. However, DC solenoids run hot.

    Have someone cycle the key on/off and see if you can hear and feel it click. If you can, and you have fuel at filter, then try cranking a few more times and post your results.
     

Share This Page