1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Can this be???

Discussion in 'Electrical' started by got-h2o, May 15, 2008.

  1. got-h2o

    got-h2o HillBilly Pimp

    313
    0
    May 10, 2008
    NW Indiana
    I found this truck on Ebay as I was nosing around. Nice truck, but when I read the EGT's on the Edge it blew my mind. It's running with an engine temp of 117, which kindof matches the dash, but a whopping 2,124* EGT's??? I know they aren't always on the money, but WOW!!! :confused5:

    [​IMG]

    [​IMG]
     
  2. BigBlueBurban

    BigBlueBurban Umm no...WAIT...yes

    98
    0
    May 7, 2008
    Grand Rapids, Michigan
    I don't think he'd have an exhaust left...
     
  3. DunesRunner08

    DunesRunner08 Banned

    1,417
    0
    May 7, 2008
    Phoenix, AZ
    Just ask gasuout....he's done that before...
     
  4. 2003bigsilverado

    2003bigsilverado Recruit

    59
    0
    May 5, 2008
    Happen to my second Edge. Had it replaced all new including the egt sensor
     
  5. busdriver75

    busdriver75 Busier than hell...

    1,258
    0
    May 7, 2008
    NW Ohio
    if that's right, there wouldn't be much boost coming out of that turbo anymore...
     
  6. Unit453

    Unit453 Cruises comfortably at 140... Staff Member Administrator

    7,124
    4
    Feb 10, 2008
    Bradenton, FL
    Thats actually happened to a few people I know. 2000 degree temos are very possible and quite probably with the right tunes. Kiss your pistons good by.
     
  7. Mad Maxx

    Mad Maxx See, what had happened was... Staff Member Moderator

    5,995
    118
    May 3, 2008
    Long Island, NY
    Bad EGT Probe. Mine did the same thing, as soon as the unit saw power it would say my EGT's were 2500+ and the truck wouldn't even be running. As I drove it said they were only 54 Degrees, Woo Hoo!! :)
     
  8. DunesRunner08

    DunesRunner08 Banned

    1,417
    0
    May 7, 2008
    Phoenix, AZ
    54 degree EGT's!!??? What are you running in the north pole with meth/water and nitrous? lol
     
  9. WanaDmxSub

    WanaDmxSub Recruit W/gray hair

    89
    0
    May 8, 2008
    I've seen 1802 on my EGT gauge SPA, Hoot mount.
    Lowest I've seen while the truck is moving and the engine runing 93.
     
  10. ZF6 MAN

    ZF6 MAN The Unwritten rule

    30
    0
    May 3, 2008
    I have seen the EGT indication and the Engine temp indication on the Edge units go bad my friend has one with both symptoms...they come and go
     

Share This Page