1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

454 with 4l80

Discussion in 'All Other Transmissions' started by tanman_2006, Aug 6, 2016.

  1. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    I have been looking for a crew cab 4x4 one ton that was in need of some repair for some time now. Next week I am going to go look at a 93 K3500 Crew Cab SRW with a 4l80.

    Now for the issue and why it's cheap.

    Trans doesn't go into 3rd or 4th. I was thinking tps or solenoid.

    Now I have a 96 4l80 out of a 6.5. I was thinking of doing a trans swap (if the 93 needs rebuilt) and using optishift to control it.

    The goal with the crew cab long bed is a p400 6 speed Allison horse trailer pulling beast. So I don't really want to dump a lot of money into it. The 4l80 was originally bought and built with the idea of building my K1500 into a race truck so a few miles on it won't kill its possible future purpose.

    What do I need to check on the 93 454 4l80 to see what might be wrong? They want 1200 for the truck and it has 120k miles on it.
     
  2. btfarm

    btfarm 300,000 Worth Staff Member Moderator

    15,859
    1,124
    May 12, 2008
    Sandwich, Illinois
    If memory serves the 93 rat was a real slug. You'll need some serious $ to get any performance out of it.
     
  3. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    I am not out for power, it will just be a DD mostly until it gets it 6.5 and 6 speed Allison swap. I just want to get it rolling cheap and run around in it.
     
  4. THEFERMANATOR

    THEFERMANATOR FRANKENBURBAN Staff Member Lead Moderator

    8,242
    1,366
    May 9, 2008
    ZEPHYRHILLS FL
    Need to scan the 93 to see whats up. If it was just 4th, I would say a temp sensor issue, but no 3rd or 4th sounds like a shift solenoid, valve body, or clutch pack issue. The 96 isn't a direct swap, but can be put in and made to work with a valve body swap and a couple of other small tweaks if it's 2 wheel drive(4X4 adds alot more work to it). The OPTISHIFT is another issue, but then you can run into issues with the ECM, trouble codes, and it not getting up to full power without finding a manual trans chip for the ECM.
     
  5. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    93 is 4x4 and 96 trans is 4x4. I don't have an issue with upgrading to a TBI chip for manual trans if the 96 4x4 trans will work.

    If I use an optishift (I have it never used it) and the 96 trans with manual chip from TBI Chips then what else will it take to make it work. I'm expecting to need a torque converter.

    Will the old paper clip scan work?
     
  6. THEFERMANATOR

    THEFERMANATOR FRANKENBURBAN Staff Member Lead Moderator

    8,242
    1,366
    May 9, 2008
    ZEPHYRHILLS FL
    Yes, the paper clip will work. Depending on what the 96 came from, it may need a converter. It should bolt in no problem, the only change I know thats required will be to swap the manual shift shaft as 93 had mechanical shift linkage, and 95+ used a cable. Your optishift should already be set up to work, but depending on which optishift you have, I'm not sure if it will shift properly on 4 low. I don't think the early ones had the 4 low input in them, but there might be a software update to add it in if you have the early optishift 1(this may not be an issue, all depends on which one with which software you have).
     
  7. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    So will the 93 linkage bolt up? This had a push button tcase and a built low stall converter. I was thinking I'd get more of a 2200rpm triple disc with the intention of building a 6.5 x att "sport truck" in the future
     
  8. THEFERMANATOR

    THEFERMANATOR FRANKENBURBAN Staff Member Lead Moderator

    8,242
    1,366
    May 9, 2008
    ZEPHYRHILLS FL
    You just have to swap out the manual shift shaft from the 93 to the 96, or you could build your own adapter to connect the shift linkage up. It isn't a big hurdle, but it is a nyisance none the less. And hang onto that 93 4l80e 4x4, people out there are willing to pay good money for the output tone wheel as GM discontinued them. I've heard the going rate is $150-200(although I've seen ads for almost $600) for that tone wheel to go on the output shaft. They frequently get damaged during rebuild, and 91-93 trucks require them to run in stock form.

    Heres a link with some info on swapping shift shafts.
    http://www.s10forum.com/forum/f213/4l80e-shift-shaft-help-505790/#/topics/505790?_k=1cv651
     
    Will L. and tanman_2006 like this.
  9. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    10-4

    The guy with the 454 left on vacation this AM so it will be Friday before I get to check it out. In the mean time I found a 98 K3500 with no fuel to cylinders for 1400 I might check out. But he mentioned ether.
     
  10. Will L.

    Will L. Well-Known Member

    5,257
    2,559
    Jan 25, 2013
    Boulder City Nv
    If he hit the truck with some quick-start-boom in a can, just inspect it closely for blowby. I have looked over a truck, flashed the cash and then told him my knowledge of the truck(usually see a can in the truck is the give away) then tell them compression/ leakdown test and I'll buy it or walk away.
    If they hemhaw about it, I jump in the middle of their sentence with "If you know it's junked from starting fluid -just say it!" The answer is usually no, and I say then lets checknit out together, and if it doesnt meet specs, youll know what it takes to fix it if you keep it or sell it to a friend.

    I've done that about 8-9 times and only once had a guy refuse. I told him good luck and walked away. Seller always wants to sell more than buyer wants to buy.

    Obviously you need to show up with tools, coveralls& gloves, etc in your rig.
     
  11. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    Yeah the ether thing and being a 3hr drive has me leary. Says he bought it 2yrs ago and hasn't had time to work on it. Previous owned had a gm crate engine dropped in I 2012, the PO also was the guy that tried ether and said it fired that way. It is easily covered in 2 years of dust sitting in a barn or shop.
     
  12. Husker6.5

    Husker6.5 135' diagonal 16:9HD, 25KW sound!

    1,101
    433
    Feb 10, 2011
    Lincoln, NE
    Using ether WITHOUT using the glowplugs is not an issue. 99% of those who use ether make the mistake of obeying the Wait to Start light and when the incoming ether on that first revolution hits a hot glowplug, BAM!
     
  13. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    I agree. I don't want to take the risk. I don't want a truck that will stay running as long as you keep ether spraying
     
  14. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    Ok finally checked out the 454...

    It hits 3k at 50ish. Is that 2nd or 3rd? Pretty sure I was still in 2nd. Runs great and pulls decent to 50mph.

    Has new solenoids, a low mile trans swap, clean fluid, and bad temp sensor. The trailer brake box is in front of the DTC port do I didn't get codes, unfortunately I didn't take tools.


    Been sitting since March and fired on the 3rd crank, maybe 5-6 sec.
     
  15. THEFERMANATOR

    THEFERMANATOR FRANKENBURBAN Staff Member Lead Moderator

    8,242
    1,366
    May 9, 2008
    ZEPHYRHILLS FL
    Sounds like you were stuck in 2nd which would be limp mode.
     
  16. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    So trans is shot? He's been driving it for 3 yrs this way. Just farm to farm on back roads. Trans fluid is bright and smells good.
     
  17. THEFERMANATOR

    THEFERMANATOR FRANKENBURBAN Staff Member Lead Moderator

    8,242
    1,366
    May 9, 2008
    ZEPHYRHILLS FL
    May be fine. Without knowing codes or seeing a data stream on it who knows. Could be as simple as a bad tps or temp sensor. Or could be fried, no telling without checking it.
     
  18. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    Well I know the ect is bad or the dash gauge failed. 4x4 works good we got it in pretty deep mud and it just dug on through
     
  19. THEFERMANATOR

    THEFERMANATOR FRANKENBURBAN Staff Member Lead Moderator

    8,242
    1,366
    May 9, 2008
    ZEPHYRHILLS FL
    Ect and dash gauge senders are 2 different parts.
     
  20. tanman_2006

    tanman_2006 Just a farm kid...

    5,366
    417
    Feb 15, 2010
    Seiling, Oklahoma
    Side note. Went and looked at a single cab 94 3500 Cab and Chassis 2wd 5 Speed TBI 350. Ran decent driving around and went about 8 miles no problem. Paid the guy with a check (local guy) and got and mile out of town when it started bucking and sputtering trying to accelerate from 50mph in 4th. After that it coughed and sputtered like a 6.5 with dying pmd all the way back to town.

    The guy gave my check back and said he had been through 3 tbi's, intake manifold gaskets, plugs and wires, and checked fuel psi. I'm guessing something is out in the cap/rotor but he's gone as far to check compression so I don't know why he'd skip the ignition.

    Any thoughts on what could be wrong with that one? No cel but I didn't try the paperclip, I was too pissed about it dying on me right after buying to care.
     

Share This Page