1. Welcome to The Truck Stop! We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your diesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • NO ADS! The site is fully functional and ad free!
    CLICK HERE TO REGISTER!

    Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

1995 4l80E suddenly lost OD and reverse.

Discussion in 'All Other Transmissions' started by Dieselhead6.5, Jan 30, 2016.

  1. Dieselhead6.5

    Dieselhead6.5 New Member

    3
    0
    Sep 22, 2014
    Arizona
    I have a 1995 6.5 vin F, been shifting perfect, went to a buddys house today everything was fine I left and immediately noticed a shift issue, stopped and turn off the truck, restarted and got on the highway to see I have no OD, stopped a few times and restarted the truck while limping home (about 10 miles), hooked up to scantech and had a code for trans input speed sensor, fount it was unplugged, plugged in noticed no reverse and still no OD. trans never got above 160°F, any suggestions?
     
  2. JayTheCPA

    JayTheCPA Well-Known Member

    1,623
    919
    Jun 13, 2011
    Annapolis, MD
    If the OBD I systems are like the OBD II systems in terms of allowing OD, the ECM needs to see coolant temps above 130* F (as measured at the thermostat housing) in addition to trans fluid temps above 70* F.

    Does the motor sound machine-gun like when the dash gauge indicates it is warm? If so, it might point to a bad ECT sending unit for the ECM.
     
  3. Dieselhead6.5

    Dieselhead6.5 New Member

    3
    0
    Sep 22, 2014
    Arizona
    engine sounds fine, scanner shows temps ate good, 1,2,3 shifts are normal, but no engine braking. I dropped the pan and there is a bit of clutch dust in it but no metal shavings, fluid didn't really smell burnt and its only been about 12k miles since I serviced it last.
     
  4. WarWagon

    WarWagon Well it hits on 7 of 8...

    8,246
    2,685
    Nov 15, 2009
    AZ
    Make sure the codes are clear and stay clear. It should code if it won't go into OD when commanded to do so. Undefined gear ratio codes mean something mechanical is broken. I think 4th and reverse are related to a single band, but, I am fuzzy on that.
     
  5. Dieselhead6.5

    Dieselhead6.5 New Member

    3
    0
    Sep 22, 2014
    Arizona
    Yep kept getting dtc 87, I'm pulling it out and ordering a reman seems as I have had too many issues with rebuilt trannys in the past. Thanks for the advice
     
  6. Sharpee

    Sharpee Ride wide open......

    5
    3
    May 27, 2018
    Lake forest california
    So what ever happened. the same is Happening to mine now
     

Share This Page