Buy Viagra with Dapoxetine online at our pharmacy. No prescription required. Lowest price guaranteed. Free Worldwide Shipping. Reorders huge Discount.
buy antibiotics online


THIS AD DOES NOT APPEAR TO REGISTERED USERS!
Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: Rough idle & misfire

  1. #1
    Tropical 6.5er matuva's Avatar
    Join Date
    May 2008
    Location
    New Caledonia. An island in south west pacific, close Australia.
    Posts
    1,902
    Member #
    137


    Default Rough idle & misfire

    A K2500 suddenly sputter and loss power while suddenly running rough and blowing a lot of white smoke.

    Thinking about injectors quitting, the guy put on new stanadyne ones. No change.

    He puts on a known good injection pump, tried 2 different PMDs. Still rough iddle and a lot of white smoke, no change.

    The truck starts really easely, iddle really rough but is able to not quit. It will respond to acceleration and is able to rev up with no problem, but boy, it really smokes

    They called me and I hooked my laptop, and here's a screenshot of what I get :

    K2500 DTCs.jpg

    I'm not really sure I understand everything DTCs mean.

    Would you help me decoding them and give me your advice ?

    Thank you for that.
    1994 full size BLAZER
    Buddy's 3 banger chip
    Low stall converter (1200-1400 rpms)
    and more ...

  2. #2
    Registered User NVW's Avatar
    Join Date
    May 2008
    Location
    Castor, AB.
    Posts
    6,750
    Member #
    110


    Default

    Matuva, did he recently fill up with fuel? Could be dirty fuel or water in fuel.
    Leo
    * 95 GMC 3500 4x4 dually, VIN "F", 4.10 gears, 4L80/E trans, 400,000km, 3" downpipe, 4" exhaust, FSD mounted on heat sink in bumper, #9 resistor, 3 pillar gauge's, High Idle kit, Bosch marine injectors, Bosch Duraterm glow plugs, Wester's perf. chip, ATT, GP overide, K47 airbox, FTB, Racor fuel filter, fuel pressure gauge
    * 98 Chev. 1500 4x4 VIN "S", 3.73 gears 250,000 km, (needs work)
    * 97 GMC C3500 VIN "F", 4.10 gears, 5 spd manual, 324,000 k (parts)
    * 04 Yukon Denali, 6.0, 196,000 km.
    * GMTD ScanTech
    * CarCode

  3. #3
    Tropical 6.5er matuva's Avatar
    Join Date
    May 2008
    Location
    New Caledonia. An island in south west pacific, close Australia.
    Posts
    1,902
    Member #
    137


    Default

    Not recently, at least not just before the troubles occur.
    I have told him to check fuel.
    1994 full size BLAZER
    Buddy's 3 banger chip
    Low stall converter (1200-1400 rpms)
    and more ...

  4. #4
    Registered User ak diesel driver's Avatar
    Join Date
    Feb 2009
    Location
    alaska
    Posts
    9,045
    Member #
    2334


    Default

    What about the ect sensor?
    96 gmc k2500 4" exhaust, marine inj, #9 resistor, GL4, turbomaster, duraterms,-1.94 TDCO,FTB, remote pmd, isspro pillar gauges, kennedy opsu relay kit,141 block, 2 1000 w block heaters, 2 150w glue on oilpan heaters, 2 150w glue on transpan heaters, 97 K47 air filter , IP replaced at 229k ,gear drive set awaiting install, Parts for intercooler waiting to be installed

    94 k1500 excab sb 6.5 plow truck. Fisher plow w/engine driven pump, F intake, h/m turbomaster, plowing chip by Buddy, remote PMD w#9 resistor, Duraterms

    96 k3500 CC 6.5 dually
    94 k2500 excab lb 6.5 parts truck
    00 burb 5.3 wifes
    70 Ford reg cab lb 428 cj richmond 5spd lockers 35s
    75 Vette built 383 needs work
    62 Tempest convertible way on the back burner project
    85 Honda VF1000R
    90 P30 Cummins BT4 work van
    90 Int SA dump w/trailer
    416c backhoe

  5. #5
    Registered User buddy's Avatar
    Join Date
    Nov 2008
    Location
    California, central coast
    Posts
    6,093
    Member #
    2043


    Default

    could fill out diagnostic checklist. Need more information.

    Is it always white smoke or ever black? No new noises? Ticking, did symptoms always stay same or change at all with new parts? Timing could be way too retarded. Does it run any better with ECT unplugged, not that the ECT is the problem. Or some air in the fuel system.

    Take snapshots of sensor data, timing data, fuel rate, etc
    94 6.5TD C1500 ECLB w/ 50 gallon aux tank/box; 235/75R17 tires on Alloy wheels; 3.42 gears; A-Team Turbo; 4" Aero Turbine 4040 muffler to 5" Aero Turbine 5050XL muffler to 6" tip before rear axle; FSD heatsink, marine injectors; "F" intake; SynBlend 10W-30 oil; Walbro FRB-5 w/ 12 micron prefilter; Feed The Beast; WMI and Propane fumigation; OPS extension & relay; 110K original miles; Engh GMTDScanTech
    Near Future: Battery relocation, Amsoil Nanofilter behind headlight, and stereo upgrades
    Veterans of America Club, member #18

  6. #6
    Tropical 6.5er matuva's Avatar
    Join Date
    May 2008
    Location
    New Caledonia. An island in south west pacific, close Australia.
    Posts
    1,902
    Member #
    137


    Default

    I'll try to fill out the diagnostic list ASAP.
    For now, :
    • white smoke, unburnt fuel,
    • no special new noise or ticking,
    • TDCOffset : -1.41, desired & actual pump timing 10.1
    • no change with all new parts.
    1994 full size BLAZER
    Buddy's 3 banger chip
    Low stall converter (1200-1400 rpms)
    and more ...

  7. #7
    Registered User buddy's Avatar
    Join Date
    Nov 2008
    Location
    California, central coast
    Posts
    6,093
    Member #
    2043


    Default

    I would try to eliminate air in the fuel system as a possibility, perhaps by running another fuel source straight to IP, instead of the system from the truck.

    Check to make sure the CPS isnt busted off its mounting tab and turned in its hole.

    Could be a PCM issue, as far as when its sending the inject signals to the PMD for the IP. Like if the CPS was not correctly positioned or PCM was going haywire. Or timing chain tooth was worn and jumped, if thats possible, so valves and injection are not opening at injecting at right time.
    94 6.5TD C1500 ECLB w/ 50 gallon aux tank/box; 235/75R17 tires on Alloy wheels; 3.42 gears; A-Team Turbo; 4" Aero Turbine 4040 muffler to 5" Aero Turbine 5050XL muffler to 6" tip before rear axle; FSD heatsink, marine injectors; "F" intake; SynBlend 10W-30 oil; Walbro FRB-5 w/ 12 micron prefilter; Feed The Beast; WMI and Propane fumigation; OPS extension & relay; 110K original miles; Engh GMTDScanTech
    Near Future: Battery relocation, Amsoil Nanofilter behind headlight, and stereo upgrades
    Veterans of America Club, member #18

  8. #8

    Default

    Maybe check compression reading on cyl 6 in particular.

  9. #9
    Walking J Designs Veg_Out's Avatar
    Join Date
    Aug 2008
    Location
    Boise, Idaho
    Posts
    733
    Member #
    873


    Default

    Along that line of a compression check...How about a pressure test on the coolant side of the house. Is there any pressure in the top hose when started cold?

    Plastic Dashboards - RattleStop it! . GM RattleStop, now $10.99 w/free shipping Dodge RattleStop Ford RattleStop

    Feed the Beast 2.0 - Stainless!

    A Team Turbos here! Over 100 sold. 100% satisfaction, or your money back. Guaranteed.

    KOJO Custom 6.5L Diesel Tune!

    Heath Diesel PMD Isolators


    BioPro Biodiesel Processors

    1995 K2500 Suburban LS. 240,000 miles. 6.2/6.5 hybrid motor. A Team Turbo, KOJO tuning. Walking J Designs RattleStop Kit, Frybrid WVO kit. Walking J Designs FTB. Secret Walking J Design parts all over it...Soon to be released.

    http://www.youtube.com/watch?v=K343JtELjbQ

  10. #10
    6.5 nut job/addict
    Join Date
    Nov 2008
    Posts
    2,599
    Member #
    2090


    Default

    I would try to eliminate mechanical issues before blameing electronics.A compression test and visual check of the valvetrain would be a good start.
    Barry



    I am not on the Heath Bandwagon

  11. #11
    Registered User bison's Avatar
    Join Date
    Jun 2008
    Location
    Near Peace River-Alberta
    Posts
    5,345
    Member #
    735


    Default

    x2
    98 GMC 2500 HD 6.5 F auto ext 4x4 engine rebuild at 268.000 km,Provent Oil seperator,Vacpump deleted,TM,all gauges,5th wheel.currently at 307.000 km
    95 GMC 2500 6.5 F auto ext sh bx 4x4 ,relocated PMD,OPS,extra glow and aux LP manual switch.In cab fuel gauge.CDR vented at 307.000 km to the atmosfeer.presently 405.000 km
    Wife's d dr.Soon to have pyro,boost,chip and TM
    89 GMC 2500 6.2 auto ext 4x4 relocated OPS 700.000+ KM denoted to ranch duty.
    95 chevy 2500 6.5 F st ext .parts truck .
    2 spare 6.5 F blocks,
    1 is a powerup project, the only 506 block in existence with no outer main cap bolt holes.

  12. #12
    Tropical 6.5er matuva's Avatar
    Join Date
    May 2008
    Location
    New Caledonia. An island in south west pacific, close Australia.
    Posts
    1,902
    Member #
    137


    Default

    Finally found enough spare time to check this K2500 again. I have no compression gauge, but an old mechanic says I must pull out the passenger head. For him, one of the valves on cyl # 6 is blown.

    Does make sense to me. Will pull the head and see.

    Will let you know.
    1994 full size BLAZER
    Buddy's 3 banger chip
    Low stall converter (1200-1400 rpms)
    and more ...

  13. #13
    Tropical 6.5er matuva's Avatar
    Join Date
    May 2008
    Location
    New Caledonia. An island in south west pacific, close Australia.
    Posts
    1,902
    Member #
    137


    Default

    Pulled the head, and found a damaged exhaust valve at cyl # 6.

    Should be fixed .
    1994 full size BLAZER
    Buddy's 3 banger chip
    Low stall converter (1200-1400 rpms)
    and more ...

  14. #14
    Registered User ak diesel driver's Avatar
    Join Date
    Feb 2009
    Location
    alaska
    Posts
    9,045
    Member #
    2334


    Default

    Your on a roll
    96 gmc k2500 4" exhaust, marine inj, #9 resistor, GL4, turbomaster, duraterms,-1.94 TDCO,FTB, remote pmd, isspro pillar gauges, kennedy opsu relay kit,141 block, 2 1000 w block heaters, 2 150w glue on oilpan heaters, 2 150w glue on transpan heaters, 97 K47 air filter , IP replaced at 229k ,gear drive set awaiting install, Parts for intercooler waiting to be installed

    94 k1500 excab sb 6.5 plow truck. Fisher plow w/engine driven pump, F intake, h/m turbomaster, plowing chip by Buddy, remote PMD w#9 resistor, Duraterms

    96 k3500 CC 6.5 dually
    94 k2500 excab lb 6.5 parts truck
    00 burb 5.3 wifes
    70 Ford reg cab lb 428 cj richmond 5spd lockers 35s
    75 Vette built 383 needs work
    62 Tempest convertible way on the back burner project
    85 Honda VF1000R
    90 P30 Cummins BT4 work van
    90 Int SA dump w/trailer
    416c backhoe

  15. #15
    Registered User buddy's Avatar
    Join Date
    Nov 2008
    Location
    California, central coast
    Posts
    6,093
    Member #
    2043


    Default

    Lets see some pics of that valve, and the piston top too
    94 6.5TD C1500 ECLB w/ 50 gallon aux tank/box; 235/75R17 tires on Alloy wheels; 3.42 gears; A-Team Turbo; 4" Aero Turbine 4040 muffler to 5" Aero Turbine 5050XL muffler to 6" tip before rear axle; FSD heatsink, marine injectors; "F" intake; SynBlend 10W-30 oil; Walbro FRB-5 w/ 12 micron prefilter; Feed The Beast; WMI and Propane fumigation; OPS extension & relay; 110K original miles; Engh GMTDScanTech
    Near Future: Battery relocation, Amsoil Nanofilter behind headlight, and stereo upgrades
    Veterans of America Club, member #18

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 11
    Last Post: 10-20-2011, 05:26 PM
  2. Running real rough and cant idle unless SES in on then it fine.
    By Dive-N-Dog in forum GM 6.5 Diesel Engines
    Replies: 33
    Last Post: 01-13-2010, 03:21 AM
  3. New IP, rough idle & white smoke
    By matuva in forum GM 6.5 Diesel Engines
    Replies: 8
    Last Post: 12-29-2009, 10:54 PM
  4. Denali 6.0L P0300 Random Misfire
    By whatnot in forum Any Other Gas Engine
    Replies: 4
    Last Post: 12-23-2009, 07:09 PM
  5. misfire.....
    By Biohzd in forum Any Other Gas Engine
    Replies: 10
    Last Post: 03-10-2009, 12:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •